Federal contract award

140R2022C0001

FKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1

Research the contractorView USAspending sourceSave to my pursuit research

Award details

Obligations, current value and potential value describe different measures; they are never added together.

FieldReported value
AgencyDepartment of the Interior
OfficeMP-REGIONAL OFFICE
NAICS237990 — Other Heavy and Civil Engineering Construction
PSCZ2KB — REPAIR OR ALTERATION OF CANALS
Parent award / vehicleNot reported
Set-asideNO SET ASIDE USED.
Pricing typeFIRM FIXED PRICE
Obligations$187.9M
Current contract value$187.9M
Potential contract value / ceiling$187.9M
Start dateOct 7, 2021
Current end dateAug 5, 2026
Potential end dateAug 5, 2026
Latest award activityAug 5, 2026
Source loadedSep 19, 2026

Funding and modification history

Showing the latest 100 of 100 loaded transactions. Negative values are deobligations.

DateModificationObligation changeDescription
Aug 5, 2026P00099$880.0KDEFINITIZE MOD 57 - CANAL AND BIFURCATED TIE-INS DEFINITIZE MOD 38 - MALLEY PROPERTY AB ROAD DEFINITIZE MOD 61 - CASA BLANCA 48 WSP PIPE BOX CULVERT DEFINITIZE MOD 64 - TURBIDITY CURTAINS REA 22 - TERRA BELLA TURNOUT WEIR BOX CANAL LEAK
May 8, 2026P00098$123.5KFINALIZE REQUEST FOR CHANGE (RFC-0008)-REVISED 3X3 BOX CULVERT INLET ELEVATIONS
Mar 25, 2026P00097$36.9KDEFINITIZE UNILATERAL MOD P00013 - RFP 18 DEFINITIZE UNILATERAL MOD P00036 - RFC 0021 - 60 INCH DEER CREEK CROSSING DEFINITIZE UNILATERAL MOD P00060 - TBID WEIR BOX DEFINITIZE UNILATERAL MOD P00079 - RFC 0039 RADIAL GATE MOVEMENTS DEFINITIZE UNIL
Aug 21, 2025P00096$23.7KDEFINITIZE UNILATERAL MOD P00022 - AVE 80 - RFI 285 DEFINITIZE UNILATERAL MOD P00032 - UNWATER TBID BORROW PIT DEFINITIZE UNILATERAL MOD P00035 & P00052 - RFP 0033 - SCE POWER SUPPLY CHANGES DEFINITIZE UNILATERAL MOD P00043 - 1" ARV DEFI
Jun 23, 2025P00095$203.0KDEFINITIZE UNILATERAL MOD P00019 - DEER CREEK CONDUIT CROSSING DEFINITIZE UNILATERAL MOD P00053 - DEMOLITION OVERHEAD AT DEER CREEK, INSTALL POWER AND DUCT BANK DEFINITIZE UNILATERAL MOD P00054 - RFC NO. 0030-SCE POWER SUPPLY AT TERRA BELLA DEFINI
Mar 4, 2025P00094$33.5KDEFINITIZE UNILATERAL MOD P00063 - CANAL STAFF GAUGES DEFINITIZE UNILATERAL MOD P00074 - ADDITIONAL GUARDRAIL INSTALL AT DEER CREEK
Feb 13, 2025P00093$11.4KDEFINITIZE MOD P00023-RELOCATE DEID-68 TURNOUT
Feb 12, 2025P00092$502.0KDEFINITIZE MOD 12, 14, 48, 49, 76
Dec 12, 2024P00091$38.1KDEFINITIZE MOD P00030-RFP 0014-SPECIFICATION NO. 20-C0907
Dec 9, 2024P00090$256.7KFINALIZE REA 00019-ADDITIONAL REBAR 9-IN BULLNOSE RADIUS
Nov 19, 2024P00089$58.0KFINALIZE REA 00019=ADDITIONAL REBAR 9-IN BULLNOSE RADIUS
Nov 14, 2024P00088$562.9KDEFINITIZE UNILATERAL MOD P00040 P00050, CLIN QUANTITY OVERRUNS, REA 0026, REA 0028, REA 0029, RFC 0035.
Sep 20, 2024P00087$315.0KCOUNTY ROAD REPAIR ISSUE
Aug 13, 2024P00086$9.1KDEFINITIZE MODIFICATION P00051-ELECTRICAL CHANGES
Aug 7, 2024P00085$52.3KREA 0017-ADDITIONAL PULL BOXES AND RC DUCTBANK DB-10B
Jul 30, 2024P00084$3.1KDEFINITIZE P00068-DEER CREEK RIP RAP EXTENSION
Jul 23, 2024P00083$120.9KDEFINITIZE P00039, PIPE ABANDONMENTS IN CANAL PRISM, AND P00047, AVENUE 88 21-INCH RCP PIPE ABANDONMENT.
Jul 11, 2024P00082$542.0KO&M RAMP GRADING AND DRAINAGE MODIFICATION
Jun 25, 2024P00081$316.8KDEFINITIZATION OF P00031, P00056 AND P00065.
Jun 6, 2024P00080$46.5KREQUEST FOR PROPOSAL (RFP) NO. 0015- AVE 88-24IN. RW PIPELINE POINT OF CONNECTION
May 30, 2024P00079$19.8KRFC0039-TIME BASED DEER CREEK RADIAL GATE MOVEMENTS
May 16, 2024P00078$15.8KTEMPORARY BYPASS AT DCTRA
May 7, 2024P00077$0TEMPORARY BYPASS AT DCTRA
May 1, 2024P00075$45.5KREQUEST FOR EQUITABLE ADJUSTMENT (REA) 0020-REPAIR, REPLACE, AND RE-ESTABLISH STRAW WADDLES DAMAGED BY OTHERS, REQUEST FOR CHANGE (RFC) 10.
May 1, 2024P00076$10.0KOVER CURRENT ISSUE AT DEER CREEK
Apr 24, 2024P00074$14.0KGUARDRAIL AT DEER CREEK
Apr 23, 2024P00073$0SEGMENT 1 AND 9 O&M ROAD PAVING
Apr 22, 2024P00072$-79.0KDCTRA FLOWMETER ISSUE
Apr 15, 2024P00071$5.0KDCTRA FLOWMETER ISSUE
Apr 8, 2024P00070$-88.7KDEFINITIZE MOD 15 (RFP NO. 0023) & MOD 20 (RFP NO. 0026)
Apr 2, 2024P00069$59.7KRFP NO. 0036-DEER CREEK PANEL SITE IMPROVEMENTS
Mar 26, 2024P00067$-25.1KREA 04-SID 24IN. IRRIGATION BYPASS CHANGES
Mar 26, 2024P00068$294.0KDEER CREEK RIP RAP PLAN
Feb 14, 2024P00066$23.6KREA 04-SID 24IN. IRRIGATION BYPASS CHANGES
Feb 8, 2024P00065$14.0KFKC GATE CONTROL & CD SCADAPAK
Feb 5, 2024P00064$20.0KINSTALL NEW STAFF GUAGES
Jan 29, 2024P00063$8.0KINSTALL NEW STAFF GUAGES
Dec 21, 2023P00060$68.0KBIFURCATION TIE-IN CHANGES
Dec 21, 2023P00061$80.0KBIFURCATION TIE-IN CHANGES
Dec 21, 2023P00062$0BIFURCATION TIE-IN CHANGES
Dec 15, 2023P00059$4.0KBIFURCATION TIE-IN CHANGES
Dec 14, 2023P00058$145.8KBIFURCATION TIE-IN CHANGES
Dec 12, 2023P00057$600.0KBIFURCATION TIE-IN CHANGES
Nov 15, 2023P00056$72.2KTRIMMER & PAVING SHORT TURNAROUND SEQUENCING CHANGE
Nov 7, 2023P00055$-36.2KDEFINITIZE UNILATERAL MOD P00005, P00006, P00021.
Oct 25, 2023P00054$5.0KUNILATERAL DIRECTION FOR RFC-0030 SCE POWER SUPPLY AT TERRA BELLA
Oct 18, 2023P00053$42.0KUNILATERAL DIRECTION FOR RFP 0035-DEMO EXISTING OVERHEAD @ DC, INSTALL NEW POWER & DUCT BANK.
Sep 14, 2023P00052$85.0KUNILATERAL DIRECTION FOR THE ADDITIONAL FUNDING NEEDED TO CONTINUE THE WORK DESCRIBED IN MODIFICATION P00035-SCE POWER INTERFACE AT DEER CREEK.
Aug 30, 2023P00051$39.6KUNILATERAL DIRECTION ASSOCIATED WITH THE CHANGES NECESSARY FOR THE REWORK OF MODIFICATION 0031 SID 12-INCH FKC IRRIGATION CROSSING.
Aug 28, 2023P00050$79.0KUNILATERAL DIRECTION ASSOCIATED WITH THE CHANGES NECESSARY FOR THE REWORK OF MODIFICATION 0031 SID 12-INCH FKC IRRIGATION CROSSING.
Aug 14, 2023P00048$110.0KRFP NO. 034-AVENUE 88 21-INCH RCP PIPE ABANDONMENT
Aug 14, 2023P00049$13.0KUNILATERAL DIRECTION ASSOCIATED WITH THE CHANGES NECESSARY FOR THE REWORK OF MODIFICATION 0031 SID 12-INCH FKC IRRIGATION CROSSING.
Jul 28, 2023P00047$34.0KRFP NO. 034-AVENUE 88 21-INCH RCP PIPE ABANDONMENT
Jul 25, 2023P00046$15.6KRFP NO. 031- ADDITION OF LADDER DEFLECTOR PLATES
Jul 21, 2023P00045$73.2KREA 05 TERRA BELLA TIE IN UTILITY
Jul 18, 2023P00044$33.7KREA 05 TERRA BELLA TIE IN UTILITY
Jul 13, 2023P00043$19.0KADD 1" ARV ON THE AVE 80 SID PIPELINE
Jul 6, 2023P00042$75.0KUNILATERAL MODIFICATION-PROCURE THE STEEL PIPE MATERIALS AS SHOWN IN DRAWING C-508.
Jun 21, 2023P00041$0UNILATERAL MODIFICATION-REVISE SECTION H
Jun 14, 2023P00040$0UNILATERAL MODIFICATION-REMOVE CONSTRUCTION OF STORM DRAIN PUMP STATION NO. 1 AND 2 FROM CONTRACT
Jun 8, 2023P00039$400.0KUNILATERAL MODIFICATION-CANAL PRISM PIPE ABANDONMENT
May 17, 2023P00038$90.0KUNILATERAL RFP NO. 0028- AGG BASE ROAD FOR MALLEY PROPERTY
May 12, 2023P00037$-44.4KRFP 29 REMOVAL OF 18 INCH PIPE
May 11, 2023P00036$325.0KUNILATERAL RFC 0021-ENCLOSE DEER CREEK WATER INTO 60-INCH HDPE PIPE
May 10, 2023P00034$-124.3KDEFINITIZE MOD 2, 8, 10, 11 AND PCO 2
May 10, 2023P00035$95.0KUNILATERAL RFP 0033 - SCE POWER SUPPLY CHANGES
Apr 7, 2023P00033$-64.2KKYTE FKC IRRIGATION CROSSING
Mar 28, 2023P00032$312.0KPUMPING TO UNWATER THE BORROW PIT.
Mar 9, 2023P00031$166.0KKYTE FKC IRRIGATION CROSSING
Feb 28, 2023P00030$587.3KRFP NO.0014- TPD & TBID BERM ADJUSTMENTS
Feb 21, 2023P00029$-19.3KRFP NO.0024-DELETE CATHODIC PROTECTION AT SID S1 AND SID S2.
Jan 26, 2023P00028$5.5KRFP 0016- CUT OFF WELL ABANDONMENT RFP 0030- REVISED TRANSDUCERS (NO COST)
Jan 18, 2023P00027$53.3MFULLY FUND THE CONTRACT.
Jan 10, 2023P00026$-91.4KVECP NO. 0003 THIMBLE ELIMINATION VECP NO. 0004 FLETCHER PROPERTY BORROW PIT
Jan 5, 2023P00024$243.0KDEFINITIZE MODIFICATION P0018
Jan 5, 2023P00025$137.1KRFC NO. 0006 - ADDITIONAL STAKING AND TREE REMOVAL RFC NO. 0013 - DEER CREEK BOULDERS AND RIP RAP
Dec 20, 2022P00023$33.0KRFP NO. 0025- RELOCATE DEID-68 TURNOUT. INCORPORATE DRAWING REVISIONS TO E-100 AND E-101 FOR RFP NO. 0021.
Dec 19, 2022P00022$60.0KREMOVE DISCOVERED TRANSITE PIPE NORTH OF AVE. 80.
Dec 15, 2022P00021$30.0KRFP NO.13- NOTIFICATION OF CHANGE-WELL ABANDONMENT
Dec 14, 2022P00020$180.0KRFP NO. 0026- ASBESTOS ABATEMENT OF 54-INCH EXISTING TBID PIPELINE
Dec 13, 2022P00019$120.0KRFP NO. 0021 - DEER CREEK CONDUIT MODS-RFIS 162 & 206
Nov 8, 2022P00018$500.0KRFP NO. 1 - TBID DCTRA TURNOUT & SID-S2 TURNOUTS
Sep 21, 2022P00017$24.2KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Sep 13, 2022P00015$27.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Sep 13, 2022P00016$15.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Sep 9, 2022P00013$90.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Sep 9, 2022P00014$75.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Sep 7, 2022P00012$0FKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jul 8, 2022P00011$15.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jun 28, 2022P00010$330.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jun 27, 2022P00009$58.9MFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jun 15, 2022P00008$125.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jun 14, 2022P00007$30.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jun 13, 2022P00005$5.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jun 13, 2022P00006$25.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jun 10, 2022P00004$55.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Jun 8, 2022P00003$91.2KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Apr 11, 2022P00002$160.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Mar 18, 2022P00001$25.0KFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1
Oct 13, 20210$65.6MFKC MIDDLE REACH CAPACITY CORRECTION PROJECT PHASE 1

Buyer contacts from matching notices

Matched on exact award/solicitation identifier and awarding agency. Source dates describe the notice, not current contact verification.

ContactRolePublished contact methodsEvidenceSource date
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceJul 7, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceJul 2, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceJul 2, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceJun 25, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceJun 11, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceJun 3, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceMay 25, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceMay 14, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceMay 4, 2021
Lowery, ClintonContactclowery@usbr.gov
916-978-5539
SourceApr 16, 2021
Lowery, ClintonContactclowery@usbr.govSourceOct 21, 2020
Lowery, ClintonContactclowery@usbr.govSourceJul 28, 2020

Research next steps

  1. Check the stated set-aside against the solicitation and current certifications.
  2. Review the award scope and buyer evidence before making a bid/no-bid decision.